CRAN Package Check Results for Package rabhit

Last updated on 2020-04-25 01:53:14 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1.4 18.35 329.49 347.84 OK
r-devel-linux-x86_64-debian-gcc 0.1.4 18.35 223.20 241.55 OK
r-devel-linux-x86_64-fedora-clang 0.1.4 395.06 OK
r-devel-linux-x86_64-fedora-gcc 0.1.4 364.28 OK
r-devel-windows-ix86+x86_64 0.1.4 67.00 277.00 344.00 OK
r-patched-linux-x86_64 0.1.4 22.17 280.65 302.82 OK
r-patched-osx-x86_64 0.1.4 WARN
r-patched-solaris-x86 0.1.4 380.50 WARN
r-release-linux-x86_64 0.1.4 14.76 246.94 261.70 OK
r-release-windows-ix86+x86_64 0.1.4 62.00 245.00 307.00 OK
r-release-osx-x86_64 0.1.4 WARN
r-oldrel-windows-ix86+x86_64 0.1.4 26.00 348.00 374.00 OK
r-oldrel-osx-x86_64 0.1.4 WARN

Check Details

Version: 0.1.4
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building ‘RAbHIT-vignette.Rmd’ using rmarkdown
    Loading required package: ggplot2
    RAbHIT version: 0.1.4
    Fontconfig error: Cannot load default config file
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    dyld: lazy symbol binding failed: Symbol not found: ____chkstk_darwin
     Referenced from: /usr/local/bin/pandoc (which was built for Mac OS X 10.15)
     Expected in: /usr/lib/libSystem.B.dylib
    
    dyld: Symbol not found: ____chkstk_darwin
     Referenced from: /usr/local/bin/pandoc (which was built for Mac OS X 10.15)
     Expected in: /usr/lib/libSystem.B.dylib
    
    Error: processing vignette 'RAbHIT-vignette.Rmd' failed with diagnostics:
    pandoc document conversion failed with error 6
    --- failed re-building ‘RAbHIT-vignette.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘RAbHIT-vignette.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-patched-osx-x86_64

Version: 0.1.4
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building ‘RAbHIT-vignette.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: ggplot2
    RAbHIT version: 0.1.4
    Quitting from lines 299-301 (RAbHIT-vignette.Rmd)
    Error: processing vignette 'RAbHIT-vignette.Rmd' failed with diagnostics:
    there is no package called 'webshot'
    --- failed re-building ‘RAbHIT-vignette.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘RAbHIT-vignette.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-patched-solaris-x86

Version: 0.1.4
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building ‘RAbHIT-vignette.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: ggplot2
    RAbHIT version: 0.1.4
    Warning: Ignoring unknown aesthetics: text
    Warning: Ignoring unknown aesthetics: text
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    Quitting from lines 299-301 (RAbHIT-vignette.Rmd)
    Error: processing vignette 'RAbHIT-vignette.Rmd' failed with diagnostics:
    cannot open the connection
    --- failed re-building ‘RAbHIT-vignette.Rmd’
    
    SUMMARY: processing the following file failed:
     ‘RAbHIT-vignette.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-release-osx-x86_64

Version: 0.1.4
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: ggplot2
    RAbHIT version: 0.1.4
    Warning: Ignoring unknown aesthetics: text
    Warning: Ignoring unknown aesthetics: text
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    Quitting from lines 299-301 (RAbHIT-vignette.Rmd)
    Error: processing vignette 'RAbHIT-vignette.Rmd' failed with diagnostics:
    cannot open the connection
    Execution halted
Flavor: r-oldrel-osx-x86_64