Functionality required to efficiently use R with MarkLogic NoSQL Database Server, . Many basic and complex R operations are pushed down into the database, which removes the main memory boundary of R and allows to make full use of MarkLogic server. In order to use the package you need a MarkLogic Server version 8 or higher.

Maintainer: Mats Stellwall <mats.stellwall at gmail.com>

Author(s): Mats Stellwall*, Abdulla Abdurakhmanov* (Code in xml2json.sjs is from https://code.google.com/p/x2js/)

Install package and any missing dependencies by running this line in your R console:

install.packages("rfml")

Depends
Imports stats, utils, methods, httr, PKI, jsonlite, XML
Suggests arules, testthat, knitr, rmarkdown
Enhances
Linking to
Reverse
depends
Reverse
imports
Reverse
suggests
Reverse
enhances
Reverse
linking to

Package rfml
Materials
URL https://github.com/mstellwa/rfml
Task Views
Version 0.1.0
Published 2016-03-19
License GPL-3
BugReports https://github.com/mstellwa/rfml/issues
SystemRequirements
NeedsCompilation no
Citation
CRAN checks rfml check results
Package source rfml_0.1.0.tar.gz